Please turn on javascript in your browser to play chess.
Help Forum

Help Forum

  1. 28 Jul '14 01:35
    It seems like I get a very loud clanging sound whenever an opponent moves a piece. It is extremely annoying, especially for other people who may be in the same room.

    I can't be 100% sure it is coming from this site, but I have been going to my games whenever I hear it and have been finding it is my turn to move even though I just moved a couple of minutes ago.

    I can't find any way to turn it off or even reduce the very loud volume on it.

    Can anyone confirm my belief and, hopefully, tell me how to remedy it???? Please.
  2. Subscriber Kewpie
    chess dummy
    28 Jul '14 02:03 / 1 edit
    If this was being caused by opponent moves on RHP there'd be a lot of happy people - we're always looking for ways to be informed immediately an opponent moves! I suspect the more likely cause is a website serving ads. Try closing each of the tabs on your browser, one at a time, and waiting for the next sound before you move on to test the next tab.
  3. Subscriber Russ
    RHP Code Monkey
    28 Jul '14 08:41
    My Settings >> My Sound Settings.

    Turn off all sounds, then confirm to yourself it is not coming from this site.
  4. Subscriber Kewpie
    chess dummy
    28 Jul '14 09:38
    Thanks Russ - didn't even know that page was there!
  5. 29 Jul '14 01:41
    Well, Russ, it may not be coming from this site if you mean that the actual sound may not be generated at the site. However, I am very sure that the trigger for the creation of the sound IS being generated there. I have been monitoring the occurrence for a while now and it always come right after someone makes a move against me. It is just too much to believe those moves aren't generating something which causes the sound to occur on my computer (MacbookPro).

    Some type of notification signal must be going from the site to me. I've tried to determine a way of turning it off at my end, but can't find a way. I guess i will have to settle for just turning off my sound when playing on RHP, although I like to listen to music some of the time and that won't be possible if I turn off the sound.

    I'm sure there must be some type of better solution, but I don't think i'm going to find it.

    Nevertheless, thanks for trying.

    David
  6. Subscriber Kewpie
    chess dummy
    29 Jul '14 02:05
    You did check the MySoundSettings page as Russ suggested, didn't you? I was very surprised to see on that page that both boxes were already ticked, and would probably have been driving me crazy except that I keep my sound turned off.
  7. 29 Jul '14 14:33
    Yes, I did that some time ago. Definitely set not to enable sounds.
  8. Subscriber Kewpie
    chess dummy
    30 Jul '14 01:28 / 1 edit
    Weird. When you do find out why it's happening, please post the answer here. As I said before, some of us would like to be informed by a sound when an opponent moves.
  9. 30 Jul '14 02:02
    Kewpie,

    I'm just guessing, but under "My Settings" there is an option to enable email notification when it is your turn to move. I believe my computer makes a sound when it receives an email. So if that option is enabled you would probably get the sound. Of course, you'd need to look at the email to see if that was the reason. Since I am trying to get rid of the sound, I haven't enabled it.

    Also, I once had an app called "RHP at Work" or something like that. It was just another version of RHP (there seem to be several versions). That one put a notification in the upper right corner of whatever screen was active whenever it became your turn to move. I can't remember for sure, but I think it also triggered a bell of some kind. I didn't want the sound, obviously, so i deleted it and went back to the basic RHP. I'm sure you could find it with Google under RHP (probably spelled out) At Work.

    I've wondered if that notification sound somehow never got deleted when I got rid of that version, but I don't know how to find out.

    Good luck.
  10. Subscriber Kewpie
    chess dummy
    30 Jul '14 03:01
    There are 5 RHP skins - redhotpawn, redhotchess, timeforchess, chessatwork, playtheimmortalgame - but there's only one site really, and whatever you do in one shows up in all the others. I use timeforchess on the tablet and immortalgame on the PC and am permanently logged in on both. Tablet has all sounds permanently turned off, PC usually on, but I never hear the sound you describe. I have a permanently pinned tab open on the PC, and if my opponent's frequent moves don't generate sounds for me I don't think they can be doing so for you. I have email notifications turned off and no ticks on my MySoundSettings page.

    Do you still get the sounds even when your browser is closed?
  11. 30 Jul '14 16:10
    Don't know, Kewpie. Since just about everything I do on computer involves use of a browser, I really don't know what would happen if no browser was open.
  12. 13 Aug '14 22:50
    I finally found my solution! Chrome (my preferred browser) has an extension called "chess@work notifier". It can be set to notify you when it is your turn to move. I had completely forgotten that I had downloaded it. I just happened to be looking at my extensions today for a different purpose and saw it was there. Naturally, I immediately got rid of it and peace and quiet now reigns in my house.