Please turn on javascript in your browser to play chess.
Help Forum

Help Forum

  1. Standard member RONOC
    On a wave
    23 Feb '06 18:21
    ok I 've been told on previous occasions that because I have an old IMAC9.2 and I am using internet explorer that the new changes will be incompatible, yes it is true the new changes make everything go into the wrong position when I try to make a move, now the advice I was given previously was to upgrade my browser to safari or firefox, I have tryed downloading these but as far as I can work out this browsers are not compatible with mac 9.2 they are only compatible with macos x what the hell am I suposed to do could some one please explain basically all i want is to upgrade my internet explorer on a mac9.2 to a browser which will enable me to use rhp in its full entirety, only those who truely know the answer please respond, preferably some one who has a 9.2 and has upgraded to enable the new features, and of course time is not on my side as I have a few games on 1 day no bank, yeah yeah I know serves me right, please help o and by the way I crap with all the techno stuff so please keep it simple , thanks in advance.....RONOC
  2. Standard member XanthosNZ
    Cancerous Bus Crash
    23 Feb '06 18:49
    Originally posted by ronoc
    ok I 've been told on previous occasions that because I have an old IMAC9.2 and I am using internet explorer that the new changes will be incompatible, yes it is true the new changes make everything go into the wrong position when I try to make a move, now the advice I was given previously was to upgrade my browser to safari or firefox, I have tryed downloadin ...[text shortened]... the way I crap with all the techno stuff so please keep it simple , thanks in advance.....RONOC
    Have you tried the legacy option on the site (Under board settings)?
    If this doesn't help then it looks likely that your only option will be an OS upgrade. You were told this was likely quite a while back when it was announced that older versions would not be supported (Thread 37750).

    PS. I have a 486 running Windows 3.11 that won't run the site properly, I don't want to upgrade it, what should I do?
  3. Standard member RONOC
    On a wave
    23 Feb '06 19:06
    Yes I tried the legacy option ...still no good, look I'm quite happy to just ditch this old mac if there isn;t a solution but the question is still can I or can't I upgrade my mac 9.2 to facilatate this site or not, some one must surely know as it stands to me that it propably can't be done but before I bin this computer I'd like to make sure that there isn;t an alternative, and like before when I asked thread 37750 like now never got a definate solution nevertheless thankyou for your responce Xanthos , I think I'll just throw this damn thing away.
  4. Subscriber Ragnorak
    For RHP addons...
    23 Feb '06 19:18
    Originally posted by ronoc
    ok I 've been told on previous occasions that because I have an old IMAC9.2 and I am using internet explorer that the new changes will be incompatible, yes it is true the new changes make everything go into the wrong position when I try to make a move, now the advice I was given previously was to upgrade my browser to safari or firefox, I have tryed downloadin ...[text shortened]... the way I crap with all the techno stuff so please keep it simple , thanks in advance.....RONOC
    I believe that Opera and older versions of Mozilla are compatible with 9.2.

    I'm sorry, but I'm not prepared to do your donkey work for you, but there is info here on versions of Mozilla which work with 9.2 here...
    http://sillydog.org/forum/viewtopic.php?t=2847

    And opera for Mac OS 9.2 can be found here...
    http://www.opera.com/download/index.dml?platform=mac&ver=6.03

    D
  5. Standard member RONOC
    On a wave
    23 Feb '06 19:23
    thankyou I'll do the donkey work but it helps if you know which way to point the damn animal, I'll give it a go then
  6. Standard member RONOC
    On a wave
    23 Feb '06 20:49
    have now also tried opera and all is not well as I can't see my pieces on the board
  7. Subscriber cashthetrash
    PoPeYe
    24 Feb '06 07:01
    Originally posted by ronoc
    have now also tried opera and all is not well as I can't see my pieces on the board
    You would think if your computer worked on every other chess site it would work on this one also without having to buy a new computer. Or work with just one or two browsers. It must really be a chore to build this site. I feel for Russ. Ahhh the stress.
  8. 24 Feb '06 08:25 / 1 edit
    I myself have a newer Mac and the new board doesn't work.
    I run system X.
    The new board looks fine on my PC, but not on my Mac.
    Am hoping there's a fix upcoming. No?
    Will try other browsers. (I use Netscape.)

    Hmm. The new board seems to work fine on Safari.
    Why not Netscape?
  9. Subscriber cashthetrash
    PoPeYe
    24 Feb '06 08:43
    Originally posted by spinit6
    I myself have a newer Mac and the new board doesn't work.
    I run system X.
    The new board looks fine on my PC, but not on my Mac.
    Am hoping there's a fix upcoming. No?
    Will try other browsers. (I use Netscape.)

    Hmm. The new board seems to work fine on Safari.
    Why not Netscape?
    It seems to me that it is crazy not to have some kind of uniform standard by which all web browsers would work. Why is this not the case? Surly Mr. Bill Gates could not be the culprit to every issue on different operating systems and every browser available. If it worked before the transitions to this new design. I ask why not now?
  10. Subscriber Russ
    RHP Code Monkey
    24 Feb '06 09:43
    Originally posted by cashthetrash
    It seems to me that it is crazy not to have some kind of uniform standard by which all web browsers would work. Why is this not the case? Surly Mr. Bill Gates could not be the culprit to every issue on different operating systems and every browser available. If it worked before the transitions to this new design. I ask why not now?
    Interesting thread. I would really not want to force a computer upgrade on anyone, just a browser upgrade if necessary. (And if you are using IE on a Mac, then an upgrade IS really necessary. MS no longer support it themselves.)

    As for standards, the problem is that even standards evolve over time, and at some point you have to decide when to move on. If the majority of users are happy with the new interface, I really am free of a lot of shackles, because I use a few tricks that I would never have dreamt would be cross browser compatible a couple of years ago.

    The site is tested on a Mac during dev (I bought a Mac mini for this purpose) but, unfortunately, it is OS X, and no, I didn't test previous releases.

    So, we will really need community input on this one.

    Not sure if this is of any use to you :

    http://www.lowendmac.com/thompson/05/1216.html

    -Russ
  11. 24 Feb '06 10:08
    Hi,
    I'm having real problems since the last site update...

    Running OS 10.4 & Safari 2.0 - BIG problems - board looks awful (getting stray images all over the place) & half the buttons don't work anymore - like analyze board. Also doesn't go to the next waiting game when you've pressed "submit move" - just sits there looking at me. I've also tried explorer - same thing. - HELP RUSS!

    Ronoc - You won't be able to use Safari on your machine as it's OS X only.
    I've tried one of my other macs still running 9.2.2 - seems to be in the same boat as my os 10 machines (see above). So I think (at least this latest problem) is to do with the site update.
    What versions of OS & Explorer are you using?
  12. Subscriber cashthetrash
    PoPeYe
    24 Feb '06 10:45
    Originally posted by Russ
    Interesting thread. I would really not want to force a computer upgrade on anyone, just a browser upgrade if necessary. (And if you are using IE on a Mac, then an upgrade IS really necessary. MS no longer support it themselves.)

    As for standards, the problem is that even standards evolve over time, and at some point you have to decide when to move on. If ...[text shortened]... sure if this is of any use to you :

    http://www.lowendmac.com/thompson/05/1216.html

    -Russ
    Thanks Russ for providing a great place to play chess. I like everyone appreciate your efforts. You have done a tremendous job and I am sure you will continue to tweak what you can to make it even better than the best. I only wish that the creators of these operating systems and browsers would be able to create a set of compatible standards by which your job could be easier. Maybe it is getting there to some degree. I hope so. The artistry you and your Dream team possess has amazed me. Cheers to you and I wish you all the best. (
  13. Subscriber Russ
    RHP Code Monkey
    24 Feb '06 11:14
    Originally posted by craigiebaby
    Hi,
    I'm having real problems since the last site update...

    Running OS 10.4 & Safari 2.0 - BIG problems - board looks awful (getting stray images all over the place) & half the buttons don't work anymore - like analyze board. Also doesn't go to the next waiting game when you've pressed "submit move" - just sits there looking at me. I've also tried exp ...[text shortened]... problem) is to do with the site update.
    What versions of OS & Explorer are you using?
    I don't have Safari 2.0 available to me, but it is fairly shocking if it no longer works when 1.3.2 is fine.

    Anyone else out there in Mac land have Safari 2?

    The options are this for the time being, either select the legacy interface from the board settings page, or try Firefox?

    -Russ
  14. 24 Feb '06 14:05 / 1 edit
    Hey Russ,
    Have tried legacy setting - same problems. Buttons / options don't work...
    BUT - the good news is.... that Firefox seems to be OK. Bit of a pain in the arse as I've not long ago moved ENTIRLEY onto safari (doh!)

    I do appreciate all the hard work (honest) just a bit annoying as I really enjoy your site & would be very upset if I could no longer use it...

    BTW - don't like Firefox - looks too XPish for my liking - but then I am a Mac user....; )
  15. Subscriber Ragnorak
    For RHP addons...
    24 Feb '06 14:09
    Originally posted by craigiebaby
    Hey Russ,
    Have tried legacy setting - same problems. Buttons / options don't work...
    BUT - the good news is.... that Firefox seems to be OK. Bit of a pain in the arse as I've not long ago moved ENTIRLEY onto safari (doh!)
    http://www.intuitive.com/blog/moving_from_safari_to_firefox_and_importing_bookmarks.html

    D