Please turn on javascript in your browser to play chess.
Help Forum

Help Forum

  1. Standard member Toe
    06 May '05 08:38
    Every time I hit "back" when browsing to/from games on the My Games page, both the games displayed and the games waiting count in the toolbar become incorrect.
    A clear-out of temp IE pages and cookies stops this for a short time, but soon enough its back. (boom boom?)
    This bug has been present for a long time now: I suspect the site as a whole has trouble with the "back" browser function.
  2. 06 May '05 10:44
    I never had any problems, maybe it's an IE-thing. How are the games displayed "incorrect"?
  3. 06 May '05 11:10
    Not an IE thing...tested it on IE and MyIE2 (Maxthon)...seems to work fine.
  4. Standard member Toe
    06 May '05 11:12
    Originally posted by Svin1
    I never had any problems, maybe it's an IE-thing. How are the games displayed "incorrect"?
    There are new games missing for example. The status of those displayed is wrong. Basically, the browser has cached a previous image of the My Games page which was not the same as the page the last time the browser displayed it. It then has no idea that the page has been updated, so doesn't bother to reload it. I think.
  5. 06 May '05 11:21
    Sounds plausible. RHP does tell your browser not to cache the "My Games" page:

    <meta http-equiv="pragma" content="no-cache">

    but I think that most browsers ignore the page cache-settings for back-operations. Use the navigation on the site or press alt+[left-arrow] followed by F5 (or whatever refresh is these days) when you want to go back.