Please turn on javascript in your browser to play chess.
Help Forum

Help Forum

  1. 28 Jun '01 21:28
    I have a Mac and it won't send any moves that I make, that is when I press the move button
    nothing happens. Any hints?
    hst
  2. 28 Jun '01 21:38
    I know Macs are better graphic machines than Pcs. Maybe it knows you
    are making a bad move. Just kidding. I couldn't resist.
    Daniel
  3. Subscriber Russ
    RHP Code Monkey
    29 Jun '01 10:05
    This site has never been tested on a Mac during development. [I
    don't own one!]

    But, the site does have 2 interfaces - a nice one for the majority of
    users [AOL, Window's Internet Explorer 5.x and better] and one 'not
    so nice one' which should work for everyone else.

    So could you provide me some more detail about which browser you
    are using on your Mac. Also, when you go to the board view, do you
    see radio buttons [peg holes] on every tile?

    Thanks,

    -Russ
  4. 29 Jun '01 18:18
    Hi, I'm using IE 4.5 and yes the buttons do appear on every square. The do highlight when clicked
    on but when I click on the move button, it highlights but then nothing happens as far as moves go.
    The only other thing that often happens is I get a message saying that there is a scripting error
    and do I want to continue with scrpts or not. It doesn't matter which I choose yes or no I still am
    unable to mve...frustrating and I koww I'll probably be told by someone out there to get a Real
    computer. But I do like my trusty old Mac Thanks
  5. Subscriber Russ
    RHP Code Monkey
    29 Jun '01 19:59
    Nothing wrong with a Mac of course, but writing code to cope with all
    platforms is a really arduous task. I've done the best I can.

    I really can't see a fix coming real soon as I don't own a Mac - so I
    can't test against it.

    Real sorry about that.

    -Russ
  6. Donation Rhymester
    and RedHotTed
    29 Jun '01 21:02
    Would running a Windows emulation program like Soft Windows make
    any difference?
  7. Null User!
    12 Jul '01 14:14
    I also can't move. I am using AOL 5.0. I do have little pegs on the tiles in everyone one of them.
    Any suggestions.

    -Bria
  8. Subscriber Russ
    RHP Code Monkey
    12 Jul '01 16:30
    The peg holes are an alternative interface - a 'catch all' for machines
    that dont support the nice interface.

    To move, select the peg holes on the tile you want to move from and
    tile to move to and then hit the move button.

    I can't test against AOL as I don't have an AOL machine set up. If
    other users are using AOL 5 and dont have problems, could they
    please respond here. Thanks.

    -Russ
  9. Null User!
    12 Jul '01 17:10
    I tried that and nothing happened. I clicked the hole that my horse is on and then clicked another
    hole in another tile and then clicked move. If someone has aol 5.0 please respond. Thanks Russ.

    -Big
  10. 22 Jul '01 18:58
    I'm using webtv. I've played 50 or so games, and I have one game that is almost over and for all intents and purposes will end in a draw. Nothing happens when I hit the move button. I can't move my man, offer draw or resign. I've played several games since this one with no problems. I've even tried archiving the game for a few days and then bringing it back out, with the same results. Any suggestions?
  11. Donation tom
    Missing in action
    06 Jul '01 09:33
    If there is a script error, there should be a button to press to get more
    details.
    If you can, get the line number and exact error message and post it
    here - someone who owns a mac or can be bothered to look up bug
    lists for mac IE4.5 may be willing to take a look at the script and do
    some diagnosis.
  12. 07 Jul '01 16:18
    Loaded on IE 5. Problem solved. hstk