Please turn on javascript in your browser to play chess.
Help Forum

Help Forum

  1. 10 Jun '18 17:47
    Its been happening for 2 days now, i can only play from my phone. Is anyone else having this problem? whats wrong?
  2. Subscriber venda
    Dave
    10 Jun '18 18:34
    Originally posted by @samuelcolmenares
    Its been happening for 2 days now, i can only play from my phone. Is anyone else having this problem? whats wrong?
    You need to give more detail, like what browser you're using , what version of windows etc.
    I only use a p.c with old versions of windows(vista) and google chrome and don't have any preoblems
  3. 10 Jun '18 22:11
    i have windows vista and im using google chrome. Everything in the page loads except from the board.
  4. Subscriber Kewpie
    since 1-Feb-07
    11 Jun '18 04:44 / 1 edit
    Originally posted by @samuelcolmenares
    i have windows vista and im using google chrome. Everything in the page loads except from the board.
    It's likely to be a cache problem. Completely clear your cache and reboot your machine, if it's something in your cache that should fix it.

    https://support.google.com/accounts/answer/32050?co=GENIE.Platform=Desktop&hl=en
  5. Subscriber Russ
    RHP Code Monkey
    11 Jun '18 11:10
    Press and hold the "ctrl" key, then tap "F5".

    If that doesn't fix this, the most likely cause is that "background images" are not being loaded - sometimes to save bandwidth. (Perhaps you have tweaked your browser options or installed software that does so?)