Please turn on javascript in your browser to play chess.
Site Ideas Forum

Site Ideas Forum

  1. 30 Mar '05 21:38
    It says: convientint
  2. Subscriber Russ
    RHP Code Monkey
    30 Mar '05 23:27
    Fixed about a month ago on my development machine, but a new major release of all the code has not been uploaded since then...so that glaring typo goes uncorrected. But since someone else has noticed it, I better fix it now...

    -Russ
  3. 31 Mar '05 15:04
    Thanks :-)
  4. Standard member Aiko
    Nearing 200000...!
    31 Mar '05 19:01 / 2 edits
    Another sort of typo; when I have only 1 game waiting, it says '1 games waiting'. That's silly...!

    Why not add an:

    if (gamesWaiting == 1)
    {
    gamesWaitingText = (gamesWaiting + " game waiting" ) ;
    }
    else
    {
    gamesWaitingText = (gamesWaiting + " games waiting" ) ;
    }

    ...or something...
  5. 04 Apr '05 19:51 / 2 edits
    or:

    gamesWaitingText = (gamesWaiting + " game" ) ;

    if (gamesWaiting != 1)
    {
    gamesWaitingText = gamesWaitingText + "s";
    }

    gamesWaitingText = (gamesWaiting + " waiting" ) ;

  6. Standard member Alcra
    Lazy Sod
    06 Apr '05 08:30 / 1 edit
    waste of code really:

    gamesWaitingText = (" Games Waiting : " + gamesWaiting ) ;

    EDIT: much shorter and much neater.



  7. 06 Apr '05 09:30
    all ur codes look c'ish so i would use t'nry operator (cos Im lazy typist):

    gamesWaitingText = (gamesWaiting != 1) ? (gamesWaiting + "games waiting" : (gamesWaiting + " game waiting";
  8. 06 Apr '05 09:34
    Originally posted by redbaron101
    all ur codes look c'ish so i would use t'nry operator (cos Im lazy typist):

    gamesWaitingText = (gamesWaiting != 1) ? (gamesWaiting + "games waiting" : (gamesWaiting + " game waiting";
    b@*&^@! smilies!!

    gamesWaitingText = ( gamesWaiting != 1 ) ? ( gamesWaiting + " games waiting" ) : ( gamesWaiting + " game waiting" ) ;
  9. Standard member Aiko
    Nearing 200000...!
    06 Apr '05 11:59
    Hmm, that's better coding...
  10. Standard member MIODude
    me, not you
    06 Apr '05 14:46 / 1 edit
    wouldn't it be just easier if he just put the s in () ?

    Game(s) Waiting.. no code needed.. just uglier
  11. 06 Apr '05 16:23
    Originally posted by redbaron101
    b@*&^@! smilies!!

    gamesWaitingText = ( gamesWaiting != 1 ) ? ( gamesWaiting + " games waiting" ) : ( gamesWaiting + " game waiting" ) ;
    A shorter one:

    gamesWaitingText = ( gamesWaiting != 1 ) ? ( gamesWaiting + " games waiting" ) : ( 1+ " game waiting" ) ;


    A smarter one:

    gamesWaitingText = ( gamesWaiting != 0)?((( gamesWaiting != 1 ) ? ( gamesWaiting + " games waiting" ) : ( 1+ " game waiting" ))"no games waiting);
  12. Standard member Aiko
    Nearing 200000...!
    11 Apr '05 23:10
    The same should apply with the messages indicator (or how one calls it). When I have only one unread message, it refers to it as 'messages'.
  13. Standard member Aiko
    Nearing 200000...!
    22 Apr '05 23:13
    And the same should apply with the reccomendation indicator (or how one calls it). When I have only one recommendation, it refers to it as 'recommendations'.